Show
Ignore:
Timestamp:
11/21/14 21:16:16 (2 days ago)
Author:
robert
Message:

From Alberto Luaces,"the current code uses the preprocessor for generating the plugin path in
a way that when CMAKE_INSTALL_PREFIX contains something along the lines
of

/usr/x86_64-linux-gnu/

it gets substituted as

/usr/x86_64-1-gnu/

that is, the string is preprocessed again, thereby making changes to
anything that matches any defined symbol, as "linux" in this example
(https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=763816).

Quoting that path directly in CMake scripts solves that problem.
"

Files:
1 modified

Legend:

Unmodified
Added
Removed
  • OpenSceneGraph/trunk/src/osgPlugins/dae/daeWGeometry.cpp

    r13531 r13557  
    551551    domPolylist *polylist = NULL; 
    552552 
    553     // make sure no deprecated indices or BIND_PER_PRIMITIVE remain 
     553    // make sure no deprecated indices or binding exist 
    554554    if (geom->containsDeprecatedData()) geom->fixDeprecatedData(); 
    555555