Version 15 (modified by jean-sebastien.guay, 6 years ago)

Added a list of standard dependencies for clarity.

Coordinating OpenSceneGraph releases with downstream maintainers

This page contains details of who is known to responsible for managing the packaging of the OpenSceneGraph binaries/source code under various software repositories, such as linux distributions. The intention of this page is to help us coordinate with OpenSceneGraph releases with the downstream maintainers and keep track of who in the OSG community will make binary packages. On this page enter the relevant info, suck as packaging pages, version info, schedules for releases, and any contact details of the maintainers.

For the maintainer curious about OpenSceneGraph release schedule and build/package please head over to our wiki:Community/InformationForMaintainers page.

Dependencies

Please note that basic packages are built using "standard 3rd party" dependencies (Maintained by Mike Weiblen for VC8sp1 and by Mattias Helsing for VC9sp1). That means that libopensceneggraph and openscenegraph-examples only link against "standard" dependencies (see below). "Special" plugins, such as COLLADA and DCMTK are treated separately and will be distributed one per package. These could be built by different people as long as they are tested to work with the "official" binary packages. See Packaging for details about optional plugin packages.

Standard dependencies:

  • curl
  • freetype
  • gif
  • jpeg
  • png
  • tiff
  • zlib

Debian

Loic Dachary (http://packages.qa.debian.org/o/openscenegraph.html)

Ubuntu/Kunutu/etc.

Ubuntu MOTU Developers

Ubuntu 9.04 release schedule

Ubuntu 9.04 is now in freature freeze so to get OSG-2.8 included we'll need to ask for a Freeze Exception

Fedora

Please enter details here.

RedHat

Please enter details here.

Madriva

Supported releases 2009/2008.1 will have 2.6.1 in contribs, updated to 2.8 once released. Upcoming 2009.1 will have the same.

Relevant entry in Mandriva's Bugzilla: [https://qa.mandriva.com/show_bug.cgi?id=47439]

OpenSUSE

Please enter details here.

Gentoo

Please enter details here.

Windows

For Windows we can conceivably have different maintainers for any given toolchain (i.e. VC++ version, MinGW, Cygwin, ...) and architecture (32 and 64 bit). Notes:

  • For Visual C++, please don't make binary packages for lower Service Packs than what is most recent when the release is made.
  • You won't find any nmake binaries since it is only a generation tool.

Visual C++ 2003 (vc71)

  • 32-bit: Please enter details here.
  • 64-bit: Please enter details here. (does vc71 even support 64-bit?)

Visual C++ 2005 SP1 (vc80sp1)

Visual C++ 2008 SP1 (vc90sp1)

MinGW

  • 32-bit: Please enter details here.
  • 64-bit: Please enter details here.

Cygwin

  • 32-bit: Please enter details here.