Version 1 (modified by martin, 7 years ago)

--

This section exists to advance the cause of OpenGL hardware and software compliance. OSG itself is highly OpenGL compliant, but frequently it exposes deficiencies in the software or hardware of various OpenGL implementations in drivers and supporting software on various operating systems. It is our goal to bring these issues to light, and categorize and document them to facilitate troubleshooting and correction by the manufacturers in question.

Developers and end-users of the OSG project can also use this page to check the compliance level of OpenGL hardware they plan to acquire, to determine if it is a wise choice or not.

It is hoped that this feedback mechanism will be the motivation to get vendors to solve their OSG-OpenGL issues in order that end-users will purchase their product more readily. The keyword SEVERE is used to mark serious problems that affect a wide range of OpenSceneGraph applications.


Known ATI bugs

Note from Robert Osfield, ATI drivers have year in year out caused far more problems to [=OpenSceneGraph=] users than all other vendors put together. The problems tend to be more severe, and sadly rarely get fixed. I call on ATI to prioritize fixing [=OpenGL=] driver bugs. This will alleviate a great deal of grief to developers and end users, as the poor quality of drivers wastes a huge amount of time, money and good will.

_July 18 2006 -- Fixed in Catalyst 6.6 for Windows_ SEVERE: swap buffers under Windows when vysnc is on locks the CPU, prevent any other threads for completing. This problem is particular damaging to any multi-threaded database paging.

To Reproduce:\\ Ensure VSYNC is on in driver settings\\ osgviewer.exe cow.osg\\ Check task manager to see 100% CPU utilization. (Cow.osg is a trivial model and does not use 100% CPU to render)\\ Screenshots made with ATI Radeon Mobility 9700, [=OmegaDrivers?.net=] Catalyst version 5.10a (6.14.10.6575):

Attach:ATIRadeonOmegaVersion.png Attach:ATIRadeonOmegaSettings.png Attach:ATIRadeonCOW-VSYNC.png

%red%July 18 2006 -- Fixed in Catalyst 6.6 for Windows%%* SEVERE: GL_SGIS_generate_mipmap doesn't work. To Reproduce:\\

# Download http://www.amazing3d2.com/free/semi_flt.zip (link currently broken -- any textured model will do though) and unzip it somewhere. # Run osgviewer a3dsemi.flt # Run osgconv --compressed a3dsemi.flt a3dsemi.ive # Run osgviewer a3dsemi.ive \\ The correct image should look like Attach:textures_fine.jpg\\ The wrong image looks like Attach:textures_bad.jpg\\ \\ On a correctly working machine, the textures should look the same, whether compressed or not. Tested on Linux Mandriva Cooker, with the ATI proprietary driver 8.19.10, the graphic card is FireGL T2 (IBM T41p Thinkpad).

* any use of GLSL user-defined generic attributes (ie: user-defined variables using the "attribute" qualifier, as opposed to built-in attributes such as gl_MultiTexCoord0) seems to prevent any geometry at all from being rendered. (Mobility Radeon 9600, driver 6.14.10.6549). See the attached .zip file for repro datafiles and instructions Attach:generic_attribute.zip

%red%July 18 2006 -- Fixed in Catalyst 6.6 for Windows%%* point sprites disappears when GL_POINT_SMOOTH is enabled (Radeon 9800, Catalyst 05.11). I modified the point sprite example found at http://www.codesampler.com/oglsrc/oglsrc_6.htm#ogl_point_sprites so it toggles GL_POINT_SMOOTH when the spacebar is pressed. Attach:point_sprite_bug.zip\\ Attach:ogl_point_sprites_exe.zip\\ Buggy output results in black screen. Working output looks like this:\\ Attach:PointSprites.jpg\\

%red%July 18 2006 -- Fixed in Catalyst 6.6 for Windows%%* wireframe rendering mode sometimes adds many spurious lines, like a spider web To Reproduce: run "osgscribe cow.osg". Alternately, run "osgviewer cow.osg" and press "w" to toggle glPolygonMode into lines. The extra lines show when glPolygonMode is set to GL_LINE used in combination with display lists. To disable display lists in the cow.osg model, open it in a text editor and change line 49 from "useDisplayList TRUE" to "useDisplayList FALSE". Confirmed on Mobility Radeon 9600, driver 6.14.10.6549 and Radeon 9800, Catalyst 05.11.

Attach:osgscribe.jpg

* another example of generate_mipmap trouble To Reproduce: run "osgsimulation", then zoom out from the globe. Attach:osgsimulation.jpg


!!Known [=NVidia=] bugs

#Active stereo goes out of sync\\ Video Card: Quadro4 750 XGL\\ Driver Version: Nvidia-1.0-6629\\ Description: In quad-buffered mode sometimes the images for the left and right eyes swap over in an OSG application. This occurs when subgraphs are being added to or removed from the scenegraph. After a few seconds it resolves. This doesn't occur with the older 1.0-4xxx Nvidia drivers.


!!Known [=3Dlabs=] bugs

#point sprites not rendering\\ Video Card: Wildcat Realizm 800\\ Driver Version: 4.05\\ Description: point sprites will not render if display lists are active.

Attachments